Problems opening Connect dashboard

Incident Report for eMabler

Postmortem

An optimization effort in the latest deployment which changed the way translation files are being served to the users contained a bug, which caused users with Norwegian language set as their preference to get only a blank page. We apologize for the inconvenience this issue caused to the affected users and will improve our test suite to catch these sort of issues earlier.

Posted Apr 01, 2026 - 11:40 EEST

Resolved

The issue has been resolved.
Posted Apr 01, 2026 - 11:36 EEST

Monitoring

A fix has been implemented and released, we continue to monitor the situation.
Posted Apr 01, 2026 - 11:21 EEST

Identified

The issue has been identified and we are deploying a fix right now.
Posted Apr 01, 2026 - 11:05 EEST

Investigating

We have received reports from some users that Connect is unable to show dashboards properly, we are investigating the issue.
Posted Apr 01, 2026 - 10:56 EEST
This incident affected: Connect.